A Basic Interpreter written from scratch for the ESP8266

Moderator: Mmiscool

User avatar
By dilettante
#60218 If I wasn't clear earlier I'm sorry.

While flashing with ESP Basic yes indeed I do see the blue LED blink a few times and then rapidly blink in a long series of quick flashes. This eventually stops and the Flasher displays a lot of rows of periods and percentages, ending with 100%. After that a few garbage chars are shown.

Reset the board. Power the board off and on. Never any WiFi AP visible and no serial terminal connecting ever sees anything but a few garbage chars after the device is reset.

Walk away from ESP Basic and then flash any other firmware to the device and that firmware runs just fine. WiFi works, serial communication works. It all works.

Come back to ESP Basic and try to flash either version 2 or version 3 and as I said flashing seems to work but afterward the device is "dead" (no WiFi, no legible serial port characters).
User avatar
By heckler
#60233 Dilettante,
I'm starting to wonder if you don't have a bad module. I seem to remember seeing something similar when I chose the wrong memory size and Flashed the model. it seemed to go well but then it never came up and ran properly. is it possible that that module has bad flash memory? That isn't exposed by Lula but is exposed by ESP basic? have you tried flashing your other module? if you have a second model I would definitely try that.

User avatar
By heckler
#60234 (Sorry for the typos... i'm on my cell phone. )

You might also try reflashing your module choosing 1 meg then 2 meg and see if it behaves any differently possibly those modules were made with the wrong flash size and/or counterfeit flash chips.

User avatar
By forlotto
#60237 This was suggested by me earlier...

Problem is he says other flash work just fine. This was the first indicator that the size of flash was not understood as LUA firmware comes in different flavors as well and it may flash on a 1mb flash while basic may not fit.

However after I thought of this I also thought if basic is indeed showing 100% it should be flashing or else it is giving a false report.

I do wonder if you are waiting to do your scan long enough I have seen where it takes an upwards of 15-20 mins to actually show during a wifi scan. And as I said before there are many instances where certain wifi equipment needs to be reset.

I was seriously hoping the OP (oringinal poster) was going to share more info so I could try to recreate the problem. But it seems that blame in their mind should rest squarely on basic flasher and that is entirely possible. In order to recreate the situation you need to know key things.

What OS are they using?
What wifi chipset or hardware are they using?
Have they tried it with their phone?
Have they waited long enough for wifi to show?
Have they waited long enough before removing power?
What was the first flash they tried on their device LUA or something else?
Have they read and tried to follow the Nodemcu ESP basic guide?
Have they tried to flash the device at least 4 times consecutively and then waited the proper time before resetting and then waited for a 5-15 minutes for wifi to show in scan?
What device are they using and what is the exact place or link they bought it from?

Also important to note the esp8266 is often not soldered well to the board this can cause intermittent issues with flashing basic while other things may flash like LUA etc I have personally experienced this one and also helped another user with this same problem! So it is obviously a common thing. The fix is to get out your soldering iron and solder each point down.

If the user were to take a video it might give itself up if they recorded the process!
They think it is a waste of time and I understand the reasoning but... here is the deal if you have ever tried to diagnose a great deal of problems for other people it is VERY COMMON that they leave the smallest bits of information out that are critical to the cause of the issue. Our ability to explain is always good in our own mind for our way of thinking but when someone else hears your explanation it WILL NOT play the same video in their minds eye because they did not physically see what the user saw and experienced.

Anyone who has fixed PC's or other devices knows what I am talking about sometimes the thingamabob that is critical to the problem is left out. So what happens at this point you must physically see or experience the issue. A well done video just may give up the ghost here I dunno no promises but it would not hurt it is free to post a video to youtube or some other site and fairly easily done. If there is a possibility that it would solve my issue I'd post a video the next guy may not even step by step pictures would speak volumes.

Anyhow I just keep hoping he figures it out I think we all do.

Check the guide in my signature. Good luck. I believe that at some point someone have covered the solution to this issue already but it is easy to do something and assume you are following through with flashing basic when you really may have followed through with one thing on the previous attempt and thought you did the same thing on the current attempt. This too is a possibility.

I do realize the frustration waiting for mud to harden and poking it with a sharp stick but such is diagnostics when something does not work as planned you must test to see what the problem is and where it is going wrong or where you are doing something wrong. The user tried the older version of the flasher and still had the problem so I am doubting it is the new flasher at all. It is likely one of those things where you must poke it with a sharp stick and wait for mud to harden.

It is important to note that this is NOT the same thing as LUA!
LUA you operate your device from serial communications interface!
Basic you typically connect to it via wifi and then you program with your web browser by visiting the IP that is standard or whatever static IP you have set if connected to an AP already.

Have you ever seen the interface in your web browser at all yet?