A Basic Interpreter written from scratch for the ESP8266

Moderator: Mmiscool

User avatar
By forlotto
#68535 you can update it via Over The Air on the Over The Air Server I put up refer to my guide viewtopic.php?f=40&t=6732 for info or visit http://www.cloudwire.tk also it is available in every version from github in the flasher folder ;)
User avatar
By chris3880
#68553 Thanks for your quick response - my apologies for missing the link to the latest firmware in your excellent guide. After 3 or 4 days of solid frustration trying to get the Basic Flasher to work on my boards, I lost concentration and hope. Trying to navigate the gitHub labyrinth as a non-developer didn't help my mood either.

Now that I've got clean flashes at last, I can set up our community water well monitoring system, running my old friend Basic. Life is good.

May I offer an observation? I think user Dilettante's and my experience may be an emerging problem where your ESPBasic Flasher fails with some new chips/boards. The clincher for me is that the NodeMCU flasher works perfectly with your .bin files.

This situation is to be expected when you're operating at the edge of a technology - you tend to think that all reported problems are "user problems", not your product's problems. And you're 95% right on that. I used to run a software development shop, so I recognize these things.

To recap: I tried your flasher with 2 boards I bought last week - the Makerfocus 12E board that Dilettante has, and a D1 mini clone. The 12E board's chip legend reads "Model ESP8266MOD, Vendor DOIT.AM", and the D1 mini reads "ESP-12N"

Both boards failed to flash with your flasher, and both succeeded with the NodeMCU flasher.
After trying your flasher (following the YouTube guy's video exactly), the LED flickered during flashing, but after reset or powerdown/up, no LED flash to signal firmware launch for either board, so I'm thinking corrupt flash.

I repeated these tests on my Win10 laptop and my Win7 laptop, with identical results. Absolutely no COMM issues (what a relief). And no board button presses for flashing were necessary - except for the reset of course.

So in my head, this is an incompatibility between these model boards and your flasher .

I'm really happy that I've found a solution with your help that I can run with now. I'll donate a few bucks toward a refreshing beverage for all you hard workers.

User avatar
By its1000
#69377 Hello all.

just giving my experience to your problem as I had exactly the same : no wifi after flashing and very strange craps typo at the end of the 100%.

the thing that drove me crazy is that I succeeded flashing in basic a lot of other modules. the problem was appearing on 2 x D1 mini modules from china. but it was extremely strange because one other module bought at the same time from the same seller was ok with ESPBasic...

I made tons of tests and at the end I finally succeeded flashing and using both ..

the solution I found was :
using a Nodemcu flasher utility the 32bits version.
putting parameters to default.
flashing using the 4Mb file basic found in the build directory
restarting the ESP with RST button
then an ESP_XXX SSID appeared.
I connect to it. but it won't give you a 192.168.4.X IP to connect to it.
just wait. try to connect to you get an error message.
then some minutes after the ESPXX:XX:XX:XX SSID appeared.
connect to it.
go to
enjoy ESPBasic web pages !!!

I really think those issues come from cheap ESP modules that are really sensitive to maybe bad soldering, or maybe have some corrupted memory.. I don't know.

Hope this will help others...
User avatar
By and
#76340 I'm a noob so excuse me if I'm stating something obvious, but I've spent most of the week trying to install esp8266basic on my new esp-01 unit....with absolute no success...until this morning!

I tried the basic flasher, esptool and now also nodemcu and with both the 512 and the 1m image, but it wasn't until I found a comment that the esp8285 chip on my esp-01 with 1m flash requires spi mode DOUT and not DIO (used on esp8266 >=4m esp-12) or QIO (esp8266 esp-01_512k units).

Setting the frequency to 40, speed to 115200 and spi mode to DIO in the NodeMCU flasher I succeeded to upload the esp8266basic and have a wonderfully working unit.

Hope this helps someone else