Page 1 of 16

No WiFi after Flash Basic 3.0.Alpha 65

PostPosted: Fri Dec 16, 2016 7:04 pm
by dilettante
New "Makerfocus ESP8266 Module ESP-12E NodeMcu LUA WiFi Internet New Version Development Board" flashed with ESP8266 Basic. Can't see the access point.

Is it "hidden" or something? If so, what are the defaults for SSID and passphrase?

I am able to flash NodeMCU (LUA) onto the device afterward and I see the AP just fine, can ping, so I think the hardware should be ok. I got AP and STA MACs from that, and I assume these values are retained after flashing Basic. Is that true?

Completely green here. If I'm lost maybe someone can put me back on track. Thanks for your patience.

Re: No WiFi after Flash Basic 3.0.Alpha 65

PostPosted: Sun Dec 18, 2016 8:26 pm
by Mmiscool
It should default to an ssid of espXXXXXXXXX

Have you tried doing a format?

When you boot up the module connect it to your computer and use a serial terminal set at 9600 and see what the boot up msgs say.

Re: No WiFi after Flash Basic 3.0.Alpha 65

PostPosted: Sun Dec 18, 2016 11:58 pm
by dilettante
Tried to format. The Flasher's Format option starts then crashes the (Flasher) program: "esptool.exe has stopped working"

I'll try the serial again but I seem to recall getting one blue LED blink and then a few garbage characters.

Tried format again. same crash. Restarted the Flasher and reflashed Basic (just in case it got corrupted by the failed format).

Tried a terminal again, at 9600bps I get a few garbage characters, different each reset.

No WiFi SSID that I can see either.

You say "espXXXXXXXXX" is the "esp" lowercase? The X's are the MAC? Well in any case it shouldn't be a hidden/non-broadcast SSID right?

I've read some people saying that the PC USB hub might not supply enough power. Enough to flash but not normal runs. Seems like a bizarre concept to me but I suppose it could be true. I think it was some MicroPython site making that claim.

I can believe that a format is needed but since the tool crashes... I suppose I might look for another formatter utility for ESP8266s. Most seem to want you to install a kitchen sink of extra junk (libraries, scripting engines, etc.).

Thanks for any suggestions you might have though!

Re: No WiFi after Flash Basic 3.0.Alpha 65

PostPosted: Mon Dec 19, 2016 7:29 pm
by dilettante
In case it helps, I found this in the Event Log for esptool.exe: