Post links and attach files for documentation here, also chat about these docs freely
User avatar
By David G
#68118 Hello, I am new to ESP8266 but I am not new to Arduino programming. I recently bought a ESP8266 listed below. I updated my Arduino to 1.8.3 and installed the ESP8266 board into it. I wanted to make sure that everything worked OK so I tried a new project called ESP8266-12E Weather (that’s what it eventually will be for). I did not even put any code into the new sketch and when I tried to compile it, I got the annoying message that says it did not work. I have included that message below. I was hoping someone can help me out and tell me what I did wrong. Thanks!!

Geekcreit® NodeMcu Lua ESP8266 ESP-12E WIFI Development Board

WINDOWS driver USB to serial CH341 / CH340 installation package
Support WINDOWS 98 / ME / 2000 / XP / Server 2003 / VISTA / Server 2008 / Win7 / Win8 / Win8.1 32 Bit / 64 and MAC
Through Microsoft's digital signature authentication
In the computer end of the USB device emulation as a standard serial devices Serial COM
It contains the serial number and identification CH34X monitoring CH34X equipment swap library.

Wireless 802.11 b / g / n standard
Support STA / AP / STA + AP three operating modes
Built-in TCP / IP protocol stack to support multiple TCP Client connections (5 MAX)
D0 ~ D8, SD1 ~ SD3: used as GPIO, PWM, IIC, etc., port driver capability 15mA
AD0: 1 channel ADC
Power input: 4.5V ~ 9V (10VMAX), USB-powered
Current: continuous transmission: ≈70mA (200mA MAX), Standby: <200uA
Transfer rate: 110-460800bps
Support UART / GPIO data communication interface
Remote firmware upgrade (OTA)
Support Smart Link Smart Networking
Working temperature: -40 ℃ ~ + 125 ℃
Drive Type: Dual high-power H-bridge driver

Annoying Message:
Arduino: 1.8.3 (Windows XP), Board: "NodeMCU 1.0 (ESP-12E Module), 80 MHz, 115200, 4M (3M SPIFFS)"
In file included from c:\documents and settings\user1\local settings\application data\arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\string:41:0,
from c:\documents and settings\user1\local settings\application data\arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\stdexcept:39,
from c:\documents and settings\user1\local settings\application data\arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\array:38,
from c:\documents and settings\user1\local settings\application data\arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\tuple:39,
from c:\documents and settings\user1\local settings\application data\arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\functional:55,
from C:\Documents and Settings\USER1\Local Settings\Application Data\Arduino15\packages\esp8266\hardware\esp8266\2.3.0\libraries\ESP8266WiFi\src/ESP8266WiFiGeneric.h:27,
from C:\Documents and Settings\USER1\Local Settings\Application Data\Arduino15\packages\esp8266\hardware\esp8266\2.3.0\libraries\ESP8266WiFi\src/ESP8266WiFiSTA.h:28,
from C:\Documents and Settings\USER1\Local Settings\Application Data\Arduino15\packages\esp8266\hardware\esp8266\2.3.0\libraries\ESP8266WiFi\src/ESP8266WiFi.h:34,
from C:\Documents and Settings\USER1\My Documents\Arduino\ESP8266-12E_Weather\ESP8266-12E_Weather.ino:5:
c:\documents and settings\user1\local settings\application data\arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\bits\allocator.h:46:75: fatal error: bits/c++allocator.h: No such file or directory

#include <bits/c++allocator.h> // Define the base class to std::allocator.
compilation terminated.
exit status 1
Error compiling for board NodeMCU 1.0 (ESP-12E Module).
This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
User avatar
By mikesdowdell
#68628 I see this is kind of old but I thought I'd chime in since I'm new here. I had similar issues initially but managed to get most resolved. I needed to update many of my local libraries to ones which have been updated with ESP8266 support (like OneWire, etc) you will likely need to do the same.