Post links and attach files for documentation here, also chat about these docs freely

User avatar
By Andoniaina
#42913 Hello,

I posted comments on the live chat but no one there.
Hence, I post the description of my pblem here.

Thank you in advance for helping me.

Here it is :

I'm trying to command a servo using the esp12-e. For this I use a level converter 3,3V <=> 5V to command the servo from the pin 5 of the ESP8266.
I use also the pin 14 to light a led after the servo has finished rotating.

The sketch uploaded from the arduino IDE worked perfectly until I brought the mechanism to my door downstairs and arriving there, the blud led on the chip is ALWAYS on.

I did nothing except the led dropped down along the way.

So when I reseted the mechanism using RST ==> GND, the blue led went ON until now. I tried to reset again but as soon as the reset is done, here we go, the blue led goes ON !

I tried the many boot mode (CH_PD and GPIO02 down whereas GPIO15 up) but nothing !!!
The blue led goes ON ON and ON

Can you help me please ? I get foolish.

Thank you.

User avatar
By mbeckwith
#42920 While I may not be able to provide a technical solution, I have run into the same thing. I do not know what causes the issue, but I have noticed that when I upload certain sketches using the Arduino IDE, upon reset the blue light stays on. This usually goes away upon the uploading of another sketch. I am guessing that there is a function that is causing the light to stay on. Would you share your code so I can try to recreate your exact issue? I would try it on mine, but I am not sure of the exact sketch I had uploaded that caused the blue light to stay on. I am also very curious about why this happens.
User avatar
By Andoniaina
#42921 It is not caused by the sketch u upload since I uploaded mine and no problem at the beginning.
But after I moved it downstairs and manipulating it with my hands, the blue led switched permanently on.
On addition, I vé Just uploaded another sketch and right after the uploading is done, the blue led goes On again.

Any solution ?
User avatar
By xtal
#42926 I would remove power, jumper GPIO) to gnd[via resistor] apply power and try reflash...
If you cannot flash the FW you are using, try same procedure with a different FW,
FW's AT - Nodemcu -- Arduino -- Basic plus others..

Persistance usually pays off with these units....