Chat freely about anything...

User avatar
By per
#6210 Hi,

I am sittting in Beijing and have bought some ESP8266 modules and I have several years experience in MCU and serial data development.

The modules are powered from a good supply and I have a USB-3.3V TTL converter connected.

Ch_PD is 3.3V
GPIO 0 connected to GND

TX and RX connected

GND and VDD connected.

I have also tried to start up the module with GPIO 0 unconnected but the data string from the module remains the same..


When I turn on the power the red led turns on and I can see a quick flash of the blue led. My serial terminal software is set up to 74880 baud and the serial communication the module sends out is below


ets Jan 8 2013,rst cause:1, boot mode:(5,0)



waiting for host



I can not get the module to accept any AT commands and I can not get the module to communicate with any firmware upgrade PC application. Ihave also used a logic analyzer to see the and the module does not respond to anything.

Could anyone please tell me what I am doing wrong?
User avatar
By per
#6242 Simple answer ..

MTD0 (also known as GPIO15) : GPIO0 : GPIO2 are the pins that control the boot mode on the ESP-07 module I have.

To be able to download new firmware the module must boot in mode 1 ( GND : GND : 3V3 ) by setting GPIO15 : GPIO0 : GPIO2

To run the module with the new downloaded firmware the module must boot in mode 3 ( GND : 3V3 : 3V3 )

For my modules when a pin should be 3.3V it is enough to leave it not connected and if it should be 0 I have connected it to GND.

Maybe this is common knowledge but I thought I would provide the solution that worked for me anyway if someone else runs into the same problem.