Chat freely about anything...

User avatar
By Acuario
#67502 I'm posting this for anyone that may experience this exception. I'm using an ESP12-E.
On reboot my ESP sat in a loop at 78800 reporting the following:

Fatal exception (0):
epc1=0x40100003, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000000, depc=0x00000000

I finally discovered it was because I had GPIO2 pulled low during boot (I had a switch connected to the GPIO).
It appears GPIO2 must be high or this exception occurs.

Hope this helps someone.
User avatar
By eriksl
#67579 At least make sure all of GPIO0, GPIO2 and GPIO15 are never directly wired to either Vcc or ground. I think that's was the root cause here. Use either pull up or pull down resistors.
User avatar
By Edd EspGuy
#94795 Hi, this is my first time ever writing something like this but after a day of struggling, I wish I knew what I did now about this dumb error. I have no idea how this error occurred but my esp-01s (1Mbyte) was stuck in this boot loop after transferring it from my pic18f45k22 to my Arduino UNO (I might have connected it wrong or something). I fixed it by using the esptool to flash the Boantong AT firmware ( to the module and instantly the boot loop/error was gone and I could interface with it effortlessly from the Arduino serial monitor. I am not sure that the GPI02 pin had anything to do with it, the module worked well on another project with the pic18 with no pull-up but I connected it to 3.3V with a 10k pull-up resistor just for safety.

Hope it helps!