Chat freely about anything...

User avatar
By JoeK
#12500 Hi Athena,

Thanks for the explanation - makes sense. Still, it would be helpfull if the ESP would return an error and not just use the channel of the sta, regardless what the CWSAP command called for.

Anyway, if running in sta+ap mode is apparently no good, what else to do about these sudden "loss of connection" problems? The behavior is really strange since it is intermittent: it works for quite a while and then suddenly, no response to pings anymore (though the ESP is still alive, it responds to AT commands). But then, after some further while the ping requests get answered again. And it goes on like this off and on and off...
I'm pretty sure it is not due to my AP or DHCP server in use. Too many people in this forum have reported similar observations. I used WireShark on a WLAN-controller to check what's going on "in the air", especially if my AP didn't forward ESP packets on or off the Wireless-realm to the wired network. But everything looked absolutely ok, just that the ESP from time to time didn't respond to ARP request ("who has IP address X.X.X.X? tell Y.Y.Y.Y") and after that things timed-out...
Please have a serious look into this. Without a stable operation the ESP is just a nice toy to play with... Thank you!!
User avatar
By fixingthingsguy
Athena wrote:Hi,

Sorry that I can't replicate your problem ... I tested in station mode, it's fine..

The only difference between us is that my Apple Airport Espress is 7.6.5 .. Maybe you could try to update your router ?

Hello Athena: I'm new here so pardon my intrusion in this point of the discussion.
I notice the wifi failure happens after 10-12 successful attempts at transmitting data to web site.
The web site in question has been receiving my data over Linksys for over a year.
So, the only clarification I ask is for all the successful attempts you have run, have they been run for a duration of greater than 10-12 attempts? Or better still 24 hours in your testing. That will be of immense help to further narrow this done in my site anyway.
Thanks and regards
User avatar
By JoeK
#12864 Hi all,

Since I complained so much about the connection problems, I think I need to report my latest findings. For a couple of days now there is a new SDK version out called 1.0.0 - suggesting things are out of beta state. Within the SDK there is also a compiled FW and a new AT command reference doc. After flashing this new version the controller seems to work quite reliable. It's now on power for more than 3 days and everytime I've tried a ping or send something to the TCP server it worked. Everything else seems to work as well - to the extend I’ve been able to test. So I'd say the ESP has made a big leap forward... :-)

Cheers, JoeK
User avatar
By Creamers
#13542 @joek,

Could you provide some links to get me (and other n00bs) started in the right direction referring to the tools or maybe post a howto to get some people started the same way with the same result ? :)