Chat freely about anything...

User avatar
By tomte76
#13643 Hi,

I can also confirm that my homebrew nodemcu, build with esp-open-sdk-1.0.0 and also against the 1.0.0 libraries, does not suffer from the wlan disconnect problem any more. Thank you to Espressif for fixing this. Unfortunately nodemcu becomes a kind of unuseable because, the heap size decreased a lot building agains 1.0.0 SDK and libraries.
User avatar
By JoeK
Creamers wrote:@joek,

Could you provide some links to get me (and other n00bs) started in the right direction referring to the tools or maybe post a howto to get some people started the same way with the same result ? :)

well... this is indeed a bit of a problem to gather all this information which is quite scattered - and it get's outdated fast: I just learned that there is again a new version out.

For a basic intro this page provides some useful help:
BTW: all recent FW versions seem to initialize again at 115 kBaud (which exceeds SoftSerial of Arduino). So you need a basic communication tool for your PC's serial port. (I have not tried to omit flashing the blank-binary, but it seems that by doing so, one clears all previous settings).

So here are the complete SDKs which contain the binaries, the command description and also a little info on what to flash where:

The best flash tool seems to be this all-Chinese program: It may seem weird at first, but it does its job. Maybe less obvious: there are tabs to select and you need to click on the second one to specify the individual binary pieces and their starting address within the ESP. After a while you'll get the idea... :-)

In order to run the flash tool, I'd strongly suggest to build a little breadboard carrier board with a USB/RS232-converter device to 3.3V Volt level and two buttons for RESET and GPIO0. (there are some suggestions to run the ESP with 5V signals which may work in the beginning, but eventually will fry the chip - so don't!)

Hope this helps a bit!? Still, you'd probably need to ask Google...

User avatar
By Creamers
#13894 Thanks JoeK,

Think I found my problem. I feed the esp with 3.3volts, but the nano rx and tx are on 4+ volt. Can it be that it's unstable and not always reacting like it should? I spent hours and hours trying many examples. None of them worked like I expected...)-:
User avatar
By irukandji
#16445 Can someone please help me with this?
So, is NodeMCU out of the equation for solving the Wifi STA issues? I'm also facing this with the latest NodeMCU firmware.

Is the 1.0.1 firmware compatible with Arduino IDE? Sorry for the newbish question but i'm a bit lost.