Page 5 of 7

Re: Flashing fw stops after 20 seconds

PostPosted: Mon Sep 21, 2015 5:26 am
by asantos

I was having a hard time flashing the esp-07 with an ftdi adaper.
I swaped it with an arduino nano, and after this i was able to flash the esp without any problem.
You can check this post to see how i wired the nano to the esp



Re: Flashing fw stops after 20 seconds

PostPosted: Wed Sep 23, 2015 12:49 pm
by TitoLuyo
Mr.Morse wrote:After a bit more digging I tried to change the esptool.py file to these values.
Tried to flash it with latest nodemcu and it got stuck at 2%..... but I tried it again and lucky me, it worked!
Uploaded the pin lua example and it also worked!
So if anybody has the same problem try changing the esptool.py and flash several times.
However my other two esp8266 esp01 won't flash to 100%. Tried several different .bin files and reaches between 2% - 79%.

Try with values even smaller
with these value the process will take a very very long time, but it will finish.
I have a chinese FIDI FT232RL Usb to TTL, which USB to TTL you use to write FW?
I think to try with CP210x or CH340G, (some people says PL2xxx have some trouble in windows, but Linux OK)

Re: Flashing fw stops after 20 seconds

PostPosted: Fri Oct 23, 2015 2:49 pm
by EdOsgood
I had several chip that had the same problem. Tried many things. Turns out to be FTDI UART isn't very reliable. Two FTDI boards failed for me. I tried two CH340 and CP2102. All worked well.
Ch340 on Aliexpress.com 57ยข

Re: Flashing fw stops after 20 seconds

PostPosted: Fri Oct 23, 2015 9:34 pm
by Julio Ribeiro
Thanks Mr Morse!

I've changed ESP_FLASH_BLOCK and it works! (at least, for 1 module...still have another to save)
In my case I put FLASH BLOCK smaller:


Download to ESP8266 firmware "AI-v0.9.5.0 AT Firmware.bin"

Now i'm getting some difficulties with sending data (AT+CIPSEND), due to a anoying message "busy s..." But , this is another battle. ;)
Thank you again for your (very handy) input!