Chat freely about anything...

User avatar
By eriksl
#81743 I think the code is now again stable enough for a new release, see #21 here https://github.com/eriksl/esp8266-unive ... e/releases

Most notable changes:
- huge improvements in the networking code, througput (you can now test the actual througput using "make test" using the "espflash" program) and robustness, since the last beta quality release.
- fixed the simple digital I/O issue not being "autostarted"

Internally there are many many changes, including the switch to gcc 8.2, including newlib 2.0 as libc, moved many tables and data to flash, which frees up about 20 kbytes of DRAM, which is now mostly statically assigned to LWIP (networking) code, improving robustness.

There used to be an internal binary representation of the config (text in flash) but it took too much DRAM memory (about 12 kbytes...). So I implemented it in another which frees this 12 kbytes. The only drawback is that every change you make gets written to flash immediately. So the config-write command has gone.

Please test and give feedback!
User avatar
By holopaul
#81745
eriksl wrote:The zip file comes with a Linux binary "espflash". Just start it and watch the usage notice. I use it like this:
Code: Select allespflash -h esp1 -f espiobridge-rboot-image.bin -W



When i run it all i get is:
Code: Select allespflash: command not found

Do i need to install something else?
User avatar
By holopaul
#81757
eriksl wrote:I think the code is now again stable enough for a new release, see #21 here https://github.com/eriksl/esp8266-unive ... e/releases


Dear Erik, something is off.
I tried to flash both OTA and plain without much success.
1. I did a erase_flash.
2. flashed v21 like this : (i added the rboot-config.bin from previous version, i still don't know if this is necessary)
Code: Select allesptool.py -p /dev/cu.wchusbserial1420 write_flash --flash_size 2MB-c1 --flash_mode dio 0x000000 espiobridge-rboot-boot.bin 0x001000 rboot-config.bin 0x002000 espiobridge-rboot-image.bin 0x1fc000 esp_init_data_default_v08.bin 0xfb000 blank1.bin 0x1fd000 blank3.bin

When i tried to connect to the esp ssid the old "espespesp" password did not work and connection was refused.

What i did next was to flash with an older version (v19), authenticate the esp on my wifi, then flashed again v21 without flash_erase so that the wifi login was not erased.
I did manage to access the esp on port 24 but encountered the following behaviour:
1. Bridge port is forced to port 1 somehow
2. When trying to set the uart speed i get this message : cannot delete config (default values)

I think this is because the overlapping config but please check it out.