Chat freely about anything...

User avatar
By martinayotte
scargill wrote:I added that esptool as advised above - doesn't see it no matter where I put it - the make file says no. Ideas?

Hi scargill,
In my case, "esptool" is located in my SDK folder /home/martin/esp8266/esp_iot_sdk_v0.9.2/esptool/esptool.
The example/at/Makefile has SDK_BASE to indicate the base path to /home/martin/esp8266/esp_iot_sdk_v0.9.2, the FW_TOOLDIR and FW_TOOL are set to default "esptool" and further in the Makefile the following line construct the final path :

FW_TOOL := $(addprefix $(SDK_BASE)/,$(addprefix $(FW_TOOLDIR)/,$(FW_TOOL)))

which then point to my /home/martin/esp8266/esp_iot_sdk_v0.9.2/esptool/esptool binary.

Hoping this help,
User avatar
By mcsa
#2583 I try my instruction on clear computer.
And received only one error error
Code: Select allmake: esptool: Command not found
make: *** [firmware/0x00000.bin] Error 127

to resolve this problem, download this archiv( and extract it in dir that exist in PATH evn. For ex in c:\minigw\bin
User avatar
By Wizzard
scargill wrote:Not QUITE as you might expect... I followed the loading instructions, put the directories into the root of C: drive, ensured the PATH was ok, I already loaded up Python a few days ago.

This is what happened when I tried the make file

CC driver/uart.c
CC user/at_baseCmd.c
CC user/at_cmd.c
CC user/at_ipCmd.c
CC user/at_port.c
CC user/at_wifiCmd.c
CC user/user_main.c
AR build/esp8266_at_app.a
LD build/esp8266_at.out
FW firmware/0x00000.bin
esptool -eo build/esp8266_at.out -bo firmware/0
s .rodata -bc -ec
make: esptool: Command not found
make: *** [firmware/0x00000.bin] Error 127

What OS are you using? Mine is XP 32-bit, maybe this is a problem?

Also, as I understand from the second post I do not need to install MinGW, I just need to put it on C: and set a proper %PATH% for that dir right? I run make simply with windows cmd.exe window and w/o any unix emulator tool is that okay? ( I tried to run it from msys with the same damn :Bad file number" error )

I was able to compile all of the code with Ubuntu VBox altrough would really prefer to use this MinGW solution...
User avatar
By Michaelo
#3104 @Wizzard
Read the second post in the thread... it contains a link to a zip with everything in it...
Worked for me on Win7 ... you might have to download the windows installer for Python27 if it reports a missing dll...

The compile ran perfectly after I fixed my path (be sure you modify your path to include all the required folders)...