Chat freely about anything...

User avatar
By Osiris
#34268
motodaddo wrote:Hi Osiris,
i've your same problems whith that module Ai-Cloud, can you post the flasher tool and latest firmware you've used, please?
I can't access to links you've posted.

Thank You! :)

Certainly!

I should mention the following things first, however;
    DO NOT FLASH 0.9.5. Apparently there is a bug in this firmware. A patch has been released and I do not know if the file I used was patched. This may be the reason why I was still having some troubles.
    I've smoked my original device. I'm not too sure what happened and before I did I picked up an additional three modules from the same vendor, and within in the same month, already had an updated firmware version.
    Since this all happened a few weeks ago, the details are still a little fuzzy. There may be some steps that can help that I've omitted, and some steps I took that may be unnecessary
      You could try flashing v1.1.1.1 from the start
      You can try using either flasher or both
      There may be an issue when flashing where the memory isn't correctly written to. I couldn't tell you if it's a user error, a SDK error, incorrect firmware issue or what. I believe these files do not require writing to any of the other memory addresses. You may want to flash the memory addresses first in case this "compiled" versions do not address all memory locations. On the other hand information at these addresses may result in the unstability. However, I would think the former was more accurate.
    There was still that "Invalid..." text at the end of the reboot. I don't remember this when I first started playing with the module, but many people say that this is common and it seems no one has really figured it out.
    I do not know if the firmware .bin files location is dependent on the SDK. That is, I think the files may have to be in the same directory as the flasher. I didn't have it this way.
If I think of any other warnings, I'll make sure to note them.

I'll try to get those files up soon. I'm currently not home, but I should still be able to get and post them.
User avatar
By Osiris
#34275 Here are the files. Please read the File comments for some reference. Let me know how it goes! ;)
Attachments
This should be the actual firmware file to flash. I've pulled it from it's folder, which includes some Chinese documents and AI's "ESP Download Tool v2.4". Again, I don't know if flash tools matter, but I've excluded the other documents.
(200.11 KiB) Downloaded 810 times
Here is Espressif's Flash tool (v1.2) for flashing multiple files (or just one). If you are getting errors the open Windows shell may give you some insight, as well as provide flashing status. I believe this and the simple flash tool are from Espressif so I do not think it would matter either way. NOTE: I've modified the tool_config.txt file to include the usual memory flash addresses. The Flash Tool also automatically saves the last user's settings, so I cleared those. There are (possibly) two additional files included. If you browse to /bin_tmp/downloadPanel1 you'll find v1.1.1.1 AT Firmware.bin_rep file. This is NOT the file I remember using, I'm not sure the purpose of this file; it may be an autosave function file after flashing (??). Also in the /combine folder you'll see a test of combining .bin files into one based on the 1.4(b) SDK and 0.50 AT firmware versions. I believe I had some success with this. Please feel free to try it if you'd like, but use it at your own risk. You shouldn't have any problems reflashing the module if you try this, but I can't guarantee it's stable enough.
(7.84 MiB) Downloaded 571 times
This is the simple flasher tool (the one I actually used, I don't know if there's any real difference between the two). NOTE: This contains the v0.9.5 firmware version that may or may not be patched.
(8.57 MiB) Downloaded 576 times
This contains both the ESP Simple Flasher Tool and firmware version v0.92.0 [sic]. This is the file that I mentioned that was "stable".
(8.66 MiB) Downloaded 636 times
User avatar
By motodaddo
#34399 Hi Osiris,
thank you for all files and advices!
I've tried all steps, i've flashed all kind of firmware that i've found but nothing to do!
The only quite"stable" firmware was the 0.92, it boots up but in some circumstances it reboots or freeze and it can't switch to AP+Station so this module become useless.
I can't find the latest firmware from Ai-thinker or similar, and i don't know how to find a working firmware for this ESP8266-01 4 MBit flash.

Is there anybody tha can help me?

below there is module a picture.
Image
User avatar
By Osiris
#35125 It looks like we have the same module (I purchased mine from Sparkfun.com). I was having similar issues with switching AP/Station modes. I'd say to just try using the "v1.1.1.1" firmware, but if it's the last one you tried, I'd doubt flashing it again would work. Perhaps just leaving it at an earlier version?

I did come across some more files you can try. I haven't tried them, so I can't guarantee them.

First you can try loading the 0.92 bin with the "at_v0.19.." files. Perhaps there is something in here with the SDK that is missing. There is a read me file and where to flash the files to.

Also, from something else I've been looking into, the AT command set has moved to the "user.bin" files for Espressif. You may need to flash the V1.1.1.1 bin file along with the other usual files (user.bin? blank.bin?, etc... try each one and combinations of is the best I could say right now).

There are also bin files that support and don't support the FOTA feature. So this may be another variable (ESP-01 should no longer be able to, but the AI versions may have retained it).

You can also just try the "AI IoT..." bin file as well. I believe this was off Espressif's boards but I don't know the details behind it.

Otherwise, you try variations of the firmware. I pulled one firmware version from the Russian ESP8266 message boards (ESP8266.ru Firmware). I don't know what makes this version so special, it could be just a generic file they saved for back ups.

Some user on the Espressif boards was kind enough add an AT command to the normal firmware version that can retrieve the time from NTP servers. You can try flashing these as well (ESP8266 NTP Firmware), use the 9.4 version as the other one had a some bug in it, I believe.
Attachments
(28.03 KiB) Downloaded 428 times
(137.1 KiB) Downloaded 442 times
(140.08 KiB) Downloaded 446 times
(277.04 KiB) Downloaded 429 times