Post topics, source code that relate to the Arduino Platform

User avatar
By BLCKPSTV
#89044
Code: Select allArduino: 1.8.10 (Mac OS X), Board: "LOLIN(WEMOS) D1 R2 & mini, 80 MHz, Flash, Legacy (new can return nullptr), All SSL ciphers (most compatible), 4MB (FS:2MB OTA:~1019KB), v2 Lower Memory, Disabled, None, Only Sketch, 921600"

panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0x1440824]

goroutine 1 [running]:
github.com/arduino/arduino-cli/legacy/builder.ResolveLibrary(0xc000043400, 0xc00061e170, 0xc, 0xc00061e170)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/legacy/builder/resolve_library.go:64 +0x1d4
github.com/arduino/arduino-cli/legacy/builder.findIncludesUntilDone(0xc000043400, 0xc0001bc780, 0x1578ca0, 0xc0000cb6d0, 0xc00004de10, 0xc0001b6b00, 0x0)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/legacy/builder/container_find_includes.go:358 +0x3db
github.com/arduino/arduino-cli/legacy/builder.(*ContainerFindIncludes).Run(0x1bacff0, 0xc000043400, 0x1bacff0, 0x0)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/legacy/builder/container_find_includes.go:152 +0x4e6
github.com/arduino/arduino-cli/legacy/builder.runCommands(0xc000043400, 0xc00059dc20, 0x20, 0x20, 0x1, 0x5d6a0, 0x1bae720)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/legacy/builder/builder.go:210 +0xdf
github.com/arduino/arduino-cli/legacy/builder.(*Builder).Run(0xc0000b3e70, 0xc000043400, 0x1bacef0, 0xc00004d7e0)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/legacy/builder/builder.go:117 +0xd28
github.com/arduino/arduino-cli/legacy/builder.RunBuilder(...)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/legacy/builder/builder.go:226
main.main()
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-builder/main.go:398 +0x800
/Applications/Arduino.app/Contents/Java/arduino-builder returned 2
Error compiling for board LOLIN(WEMOS) D1 R2 & mini.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


I found a similar solution on a windows. But don't know how to fix this on a mac.
User avatar
By QuickFix
#89045 I'd say the build of the Arduino IDE you're using is at fault.
Have you tried another (older) version?

I'm sorry if I talk sh*t: I don't know anything about Apple devices. :oops: