Post topics, source code that relate to the Arduino Platform

User avatar
By imanseau
#87268 I've been at this all day and can't solve my issue. I read and followed a few tutorials on setting up OTA on a NODEMCU 12e board. I plug in the board with the USB and flash the basic OTA. No issues, after the flash it shows up as a network port in the Arduino IDE.

At first, I was having issues with it not connecting, disabling Windows 10 firewall corrected that. With the firewall disabled I can actually start an upload. The upload acts like it is doing something for about 25 seconds, then I get "[ERROR]: Error Uploading""

Back to google and the tutorials I went, came across Termite to act as my serial monitor.

With Termite running I can now see a bit more. I try and upload in the Arduino IDE to the Network Port, it does the same thing. Starts the upload, in Termite I can now see a connection has been made, the upload starts. It runs for around 25 seconds, it takes that long to make it to the second to last 0%, the Arduino IDE errors out again, about 10 seconds after the Arduino IDE gives up one last 0% and then the 1% shows up in Termite followed by "Error[4]: End Failed"

I have now tried this on two boards, the second brand new out of its package, with the same results. Even more frustrating, I can't use the serial to flash either board now. I am at a loss of how to correct this and hoping someone has run into this same issue and can point me in the correct direction.

I am using the BasicOTA example only changing the WiFi info. On the first board I tried uploading my project, thinking maybe it was something with my code. On the second board I used the BasicOTA example again, and for the OTA attempt all I did was uncomment out the line for defining the hostname.

I really want to get OTA working on this project, but at this point just recovering the 2 boards will feel like a victory. From everything I have read about OTA, the upload should be quick and it takes a long time for it to error out, I think it is some timeout issue. Who knows though, definitely not me, hopefully, you!

Termite Log ------------------------------------------------------------
IP address:
Start updating sketch
Progress: 0%
Progress: 0%
Progress: 0%
Progress: 0%
Progress: 0%
Progress: 0%
Progress: 1%
Error[4]: End Failed

Update -----------------------------------------------
I did figure out how to recover the two boards. Holding the flash button while plugging the USB into the computer allows me to flash over serial again.