Discuss here different C compiler set ups, and compiling executables for the ESP8266
User avatar
By riker1
#72436 Hi
I am having 2 setups to get the ESP up and running.

1. UART USB Cable straigt to ESP01
2. Arduino Uno and ESP01 attached.

I am confused - found different information about wiring them up.

- RX -> RX vs. RX-> to TX, vice versa.
Different setups with resistors and capacitators, some without any ...

i tried all....

now I have the problem.
not getting an AT ok!

and while uploading - diffent technics used: reset (rst -> gnd) and flash (gpio -> gnd)- used.

I get errors:
warning: espcomm_send_command: wrong direction/command: 0x00 0x08, expected 0x01 0x08


maybe anyone can solve my confusion.

Thanks T


Sketch is very easy and working on an NodeMCU .
I tired upload via Arduino IDE with Generic ESP6288 Board.

Different bauds as well.

Thanks for helping !!

warning: espcomm_send_command: wrong direction/command: 0x00 0x08, expected 0x01 0x08
resetting board
trying to connect
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
serialport_receive_C0: 00 instead of C0
trying to connect
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
espcomm_send_command: receiving 36 bytes of data
warning: espcomm_send_command: wrong direction/command: 0x00 0x08, expected 0x01 0x08
trying to connect
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
espcomm_send_command: receiving 36 bytes of data
warning: espcomm_send_command: wrong direction/command: 0x00 0x08, expected 0x01 0x08
resetting board
trying to connect
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
serialport_receive_C0: 08 instead of C0
trying to connect
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
espcomm_send_command: receiving 36 bytes of data
warning: espcomm_send_command: wrong direction/command: 0x00 0x08, expected 0x01 0x08
trying to connect
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
espcomm_send_command: receiving 36 bytes of data
warning: espcomm_send_command: wrong direction/command: 0x00 0x08, expected 0x01 0x08
User avatar
By Laurent31
#76166 Hi,

I have got the same error (00 instead of C0). I Just cannot understand what happens

Have you fixed the issue ?

Please advise

Laurent
User avatar
By QuickFix
#76246 If new, buy a development board first. :idea:

See my signature, it's there for a reason (since so many new people fail trying to get the ESP-01 to work).
An ESP-01 costs $1.50, a development board twice that amount (~$3), but you'll get an instantly working setup.

Don't try to make things harder for yourself than necessary; it will only demotivate you. :o
User avatar
By MichaelJoync
#77376 The idea of this forum is for people who still dont understand their error message

Please submit a Mantis issue instead for this.
Please make sure you select eC Compiling Tools project.

Thanks,

Jerome