Discuss here different C compiler set ups, and compiling executables for the ESP8266

User avatar
By brucehvn
#5894 I'm wanting to do some custom development with the ESP8266. I've followed the instructions in the toolchain post and am able to build the examples with no problem (except the AT_DEMO, but that I'll figure out later). I can build with both the new 0.9.4 and the older 0.9.3_14_11_21. The problem seems like my board will only act properly via the serial monitor if I flash the official firmware from the Google code page. When I flash from my built binaries, the text that comes out when I power up the board is unintelligeable, (no ready) and it doesn't seem to respond to any AT commands. In most cases, it looks like it's a baud rate problem, though I use 9600 with the official firmware. I've tried every baud rate from 4800 to 115,200 and I can't make out whatever it spits out readable and allow me to type in commands. I saw some post where someone said that if there's a boot error, it outputs at 75,000 baud. That seems very odd, but I tried that as well and couldn't get the error message they described.

I guess my first question is with these examples (blinky, basic_example, iOt_Demo), should we still see the normal (ready) message at power up and should we be able to interact with the board using AT commands? I guess I'm a little unclear about where the AT interface is located and whether when we build the examples, we are building that too and flashing it.

For instance, the blinky program looks like it just toggles GPIO2 every 10 seconds or so. I haven't hooked an LED up to it to see if that's working, but I do see a couple characters spit out on the serial console about every 10 seconds. But again, nothing readable, and no interaction from my part is accepted.

The basic_example program, just spits out a continuous stream of unreadable characters if I have the serial console running, so I have no idea if it's working properly.

The iOt_Demo program spits out what seems like it would be about the right number of characters at powerup, but again, unreadable. And it doesn't seem to respond to any of my commands as well.

Since there's not even a readme file for any of these examples, it's hard to know what I should expect from these things.

When flashed with the official firmware everything works just as it should. I haven't seen any quirks or strange behavior. I can connect to my network, ping the ESP, it's all good. But I really want to see if I can get some custom firmware running properly before I dive in and start coding something.
User avatar
By brucehvn
#5918 Just to add to the info, I've confirmed that when loading the blinky sample firmware, an led hooked to GPIO2 does in fact blink on and off every few seconds as it's supposed to. However, here is an image of what I see on the serial monitor when starting the board at 9600 baud. I've tried all the other baud rate choices, but none give me anything readable. So, is this correct, or am I supposed to be able to interact with the board? I don't know if I mentioned this in my previous post, but this is on Ubuntu 14.04.
You do not have the required permissions to view the files attached to this post.
User avatar
By villTech
#5922 iot and blinky sample will not respond to AT command and no "ready" msg on power up.

easiest way to compile the samples is to use espressif lubuntu vm.