Discuss here different C compiler set ups, and compiling executables for the ESP8266

User avatar
By Steven1811
#56570 Hello,
I'm having trouble getting an example project compiled. What I did to compile pfalcon's esp-open-sdk.

Code: Select allsudo apt-get install make unrar-free autoconf automake libtool gcc g++ gperf \
    flex bison texinfo gawk ncurses-dev libexpat-dev python-dev python python-serial \
    sed git unzip bash help2man wget bzip2

Code: Select allsudo apt-get install libtool-bin

Code: Select allgit clone --recursive https://github.com/pfalcon/esp-open-sdk.git

Code: Select allmake STANDALONE=y

After compilation I did:
Code: Select allexport PATH=/home/steven/esp-open-sdk/xtensa-lx106-elf/bin:$PATH

So after the toolchain is now built, I've gone into the sdk folder and copied the at example to /sdk/app, ran the gen_misc.sh and I got this error messages:

Code: Select all../../Makefile:103: warning: overriding commands for target `clean'
../Makefile:300: warning: ignoring old commands for target `clean'
../../Makefile:180: warning: overriding commands for target `ESP8266_NONOS_SDK_V1.5.4_16_05_20/.dir'
../../Makefile:169: warning: ignoring old commands for target `ESP8266_NONOS_SDK_V1.5.4_16_05_20/.dir'
You cloned without --recursive, fetching submodules for you.
git submodule update --init --recursive
make -C crosstool-NG -f ../Makefile _ct-ng
make: *** crosstool-NG: No such file or directory.  Stop.
make: *** [crosstool-NG/ct-ng] Error 2

What can I do to fix this issue? I also tried the exact same thing on Lubuntu 16.04 and I get the same error message.
User avatar
By KevinA
#57307 At least it didn't blow up when you compiled! I found that sudo created subdirectories owned by root. cd ~ chown -R kevin:kevin esp-open-sdk fixed that issue and /home/kevin/esp-open-sdk/make clean and then make produced a working compiler. But like your experience Things blew up when I did make in the sdk directory.
Where did you get gen_misc.sh from?
Where do you set the parameters for the ESP memory?
In sdk/bin all the sdk 2.x stuff has been compiled, no idea how or for what or how to load it.