Discuss here different C compiler set ups, and compiling executables for the ESP8266

User avatar
By gerardwr
Fadi wrote:the only thing I have yet to try is the esptool, which I think I will in the next few hours.

Fingers crossed!

My "assignment" for this week is getting esptool.py to communicate to my ESP8266.

Considering your experience with self-built code I initially intend to use a pre-build binary that is known to work for others. Like the latest firmware from Espressif.

I assume that you have tried that successfully?

BTW, do you use the Lubuntu VM, or another platform?
User avatar
By Fadi
#2184 @gbit
Incidentally, I was looking at the board just before checking the forums. and Indeed it is the EX chip. ESP8266EX.

I tried esptool.py without much success just like the other tools.
Actually I did try the IoT Demo and the AT firmware in the SDK (both standard as is, without modification to code) and failed to work.

I was able to flash the 0.2.2 firmware that is just a single file (not two bins) found on some websites providing the updated firmware, but
now I can't get it to flash again. Not sure if I bricked it or not. (if that is even possible! based on what I read, we should not be able to).
User avatar
By pcsrule
#2216 I seem to be having a similar problem. No matter which flash tool I use I can't seem to get anything other than a single .bin file like the AT image to successfully boot. All self compiled images and even images from other people with multiple files just will not boot. I'm beginning to think these two .bin files aren't to be written to 0x00000 and 0x40000 after all. I'll pick apart one of the stock .bin files in a hex editor and see if I find anything interesting.

Edit: I tried a hex editor and it seems 0x00000 and 0x40000 are reasonable. After much frustration I tried the esptool.py script to flash the chip and it works! I must have missed something the last time through with this programming tool.
User avatar
By MrLight
#2552 Hi all,
I'm trying to complie the IoT Example out of the 0.9.2 SDK and always when I'm calling make i get this Error:
Code: Select allmake: Nothing to be done for `FORCE'.

BUT it has worked a few days before.... Today I'm not able to get it working. I although have reinstalled the VM but without any luck..
Can anyone give me a hint?
Thanks a lot!

PROBLEM SOLVED: To use the given Makefile from the IoT Example it is not possible, to compile out of the example subfolder. So just copy the IoT Folder in the sdk root...