Discuss here different C compiler set ups, and compiling executables for the ESP8266

User avatar
By josemar.bool
#69145 Hi everyone.
I have a problem with unofficial SDK v2.2.1 witheclipse Oxygen on Windwos 8.1 (With old version of SDK works).

I installed java JDK, installed eclipse in C:, installed MinGw, installed the SDK 2.2.1 and run the script for install extra packets for MinGw (everything as admin).

I Launch eclipse, import examples and add the path for auto complete. But, when i try compile the blinky example I have one error with file eagle.app.sym:

Code: Select allmingw32-make.exe -f C:/Espressif/examples/ESP8266/blinky2/Makefile all
CC user/user_main.c
AR build/app_app.a
LD build/app.out
Run objcopy, please wait...
objcopy done
Run gen_appbin.exe
Traceback (most recent call last):
  File "gen_appbin.py", line 273, in <module>
  File "gen_appbin.py", line 145, in gen_appbin
IOError: [Errno 2] No such file or directory: './eagle.app.sym'
../common_nonos.mk:230: recipe for target 'build/app.out' failed
mingw32-make.exe: *** [build/app.out] Error 255

I tried uninstall programs, clear all packet of MinGw and reinstall every one program again but had the same error.

Somebody had that problem?

User avatar
By masterval
#70519 Hello everyone. I am new programming the esp8266 in the SDK and I followed the steps to install this devkit and everything perfect. But, I have problems with SDK RTOS.

The problem is that at the moment of flashing my esp8266 with the examples "esp_rtos_sdk_example" and "esp_rtos_sdk_example_2" does not do any action as if the bin files were blank. It does not even do something as simple as printing something on the terminal using the print function or os_print.

My amica module and my esp-01 work with non_os-sdk, arduino, nodemcu and micropython and work perfect, except with rtos.

Does this happen to anyone?
any solution?

I would appreciate any help, thanks.