Here we can all chat about fixing the AT+ command structure and the associated responses.

User avatar
By sraposo
#28873 Hello

It´s my first post and probably as the most of you, here a I am after spending too much time trying to solve such a mysterious problem. Indeed, a lot of problems have already been found and solved after many, many hard days, but now I have something really tough:
I can´t get a refreshed page on a ESP8266 set as a server (AT+CWMODE=3, AT+CIPSERVER=1,80) and to accept multiple connections (AT+CIPMUX=1).

I can have the page loaded and exhibited by the browser, but only once. After AT+CIPCLOSE=<id> command as a result of finishing page load on browser, any AT command after that doesn´t work and a "busy p..." message is showed. Only a reset to make it operative again.

I could not find any clue on dozens of ESP8266-related pages I´ve found and now I have no idea what is causing that. Too many days have been spent reading documentation and experimenting all sort of things.

Any clue?
User avatar
By red_car
#28994 Ok... so fixing this in my case is not so easy.

The ESP05 has GPIO0 pin permanently connected to VCC. Needs to be connected to GND for flashing... which means cutting a tiny PCB trace and connecting to GND. It looks hard... but I might give this a go later in the week.

I tried using the AT+CIUPDATE cloud update.. this seems to go through all 4 steps... but then gets an error.. and no update is done. So I think manual flashing is the only way to go to get to v0.22