Post topics, source code that relate to the Arduino Platform

User avatar
By Torjus
#28938 Hello

I have just obtained an ESP8266

I'm trying to flash this little sucker with some new firmware, but to no avail.
I use the ESP Flash Download tool V0.9.6
Sometimes i get this message:
Code: Select allsp_init_data_default.bin_rep
test running : False
serial port opened
chip sync ok!
read reg error
com closed

CrystalFreq 26M

SPI Speed is set to 40MHz
Flash Size 8Mbit

Baudrate 115200

I have tried searching the all mighty web, but have found no one who has had the same problem as me. I hope someone here can help me with this

PS: I'm trying to do this through my Arduino UNO. The ESP8266 is connected to GND and 5v and RX to RX and TX to TX

Now i got this:
Code: Select allErasing flash...
head:  8 ;total: 8
erase size :  163840
erase flash error
com closed

Edit: Figured out the issue with the flashing, though kind of embarrassing!
The sketch on which my Arduino was running was the "SoftwareSerialExample". This was interfering with the upload.
I uploaded a bare-bone code:
Code: Select allvoid setup() {
void loop() {

Which solved everything! :D

I will leave this here, just to remind myself of my embarrassment!