Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By Erno Marton
#33966 Hello,

I bought 3 pcs of esp-12 from and the first one I'm testing shows the same issue as described in the initial post.
Also, these have GPIO6 label where the GPIO0 should be, see attached img.
When checking the serial console at 76800 , this is what I get (setup done as described in the first post):
GPIO0 -> GND : ets Jan 8 2013,rst cause:2, boot mode:(1,6)
GPIO0 -> floating or to VCC with 10k: ets Jan 8 2013,rst cause:2, boot mode:(3,6)

According to what I found on some other page, the GPIO0 appears to be pulled down fine, also all other pin voltages look ok:
reset causes:
1: normal boot
2: reset pin
3: software reset
4: watchdog reset

boot device:
1: ram
3: flash

Anyone figured out any solution for this, or it's just a bad batch .... again.
You do not have the required permissions to view the files attached to this post.
User avatar
By Luwani Lino
#34267 Hey, i have the nodemcu 0.9 and i was getting the same type of messages. it also uses the esp12 . so i checked the schematics for the device and it says that when powering on the device:
gpio0 low,
gpio2 high, (the esp12 led turns off, dont worry it's supposed to)
gpio15 low.
(and yes you should do this everytime you power it on)
after you plug it in you can disconnect 15 and gpio2.

best of luck
User avatar
By bpop
#34537 I am not sure of you got a solution for this problem but I encountered the same issue with a selfbuild PB of mine. The firmware download justs stopped at 5%. At this point the PB was powered with its own 3.3V supply. When I disconnected this and used only the FTDI232 com board 3.3V supply, the firmware downloaded succeeded from the first try. Still not sure why but I hope this can help. ;)
User avatar
By dduley
#37248 Has anyone figured this out yet?? I have a few of the Banggood ESP-12 modules and they all do the same thing. All I can get out of them is the boot message at 76800 baud then they do nothing. No AT commands at any baud rate and they won't reflash with any of the tools I have tried so far. The NodeMCU flasher will get the mac address but that's as far as it goes. The boot message will change value depending on the state of GPIO0, GPIO2 and GPIO15. I went and bought an ESP-12 from ADAFRUIT and it works as advertised.
It "feels" like the Banggood modules should be able to work if only there was a way to upload the AT or other firmware.

Anybody get these things working????