Chat freely about anything...
User avatar
By BiboyMusic
#65998 Hi,

I've been using ESP8266 for quite sometime so I know the basic stuff about it.


Yesterday I tried to upload a sketch on my ESP-01 and while it was doing so, I accidentally touched the wires and it halted the upload at a certain percentage. Now I cannot communicate to it anymore. On power-on the blue led does not light slightly anymore.

I have a CH340 programmer for ESP-01 but it wasn't with me yesterday (left at home) so I decided to use my UNO (Chipped removed) to do so. I've been using the UNO to upload sketch a lot of times even since before I had a dedicated programmer.

Is this still salvageable? I mean I tried everything suggested here in the forums but I still get:
Code: Select allwarning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed

I just wanted to give closure before I throw this one away. I live in a place where things like these are a scarce.

Today I already have the CH340 programmer and it still won't upload. I tried other ESP-01 and ESP-01s and they are all good.
User avatar
By QuickFix
#66023 I (firmware-) bricked my ESP-12E a couple of days ago and tried everything to get it working again.
In the end I managed to get it respond again after following the steps outlined on this page.

Since my ESP (obviously) didn't respond to my console, I directly stepped over to the "ESP Flash Download Tool"-part (at around 20% of the page) and thank God, it responded again after having flashed it with the "ESP8266_NONOS_SDK-master"-binaries using the older v2.4 of the ESP download tool (the v3.4.4 version didn't accept my ESP). :?

Because you accidently shorted some wires, there is the possibility you've actually fried it and there's no way in getting it back again, but you can always try. ;)