So you're a Noob? Post your questions here until you graduate! Don't be shy.

User avatar
By ratfink
#73447 I have been working with a NodeMCU 12E module using a custom firmware from the NodeMCU builder site and as I am on windows using the NodeMCU flasher GUI without problems. I want to port my project to the Wemos D1 module for some of the units I will be building and cannot get any firmware to properly boot after flashing. I have read up on the module and seen about having to add the bootloader to the first part of memory and whilst in theory the GUI flasher should work it doesn't so I have been trying the for the job. In all cases the flash completes but the system will not boot, simply spewing the csum error at 74880 baud on the console.
For example:
Code: Select allpython -p com33 erase_flash
python -p com33 flash_id
python -p com33 -b 115200 write_flash -ff 80m -fm dio -fs 1MB 0x0 boot_v1.7.bin 0x01000 firmware.bin

at the command prompt and
Code: Select allPORT OPEN 74880

Communication with MCU..Got answer! Communication with MCU established.
AutoDetect firmware...

Can't autodetect firmware, because proper answer not received (may be unknown firmware).
Please, reset module or continue.
boot mode:(3,6)

load 0x40100000, len 2592, room 16
tail 0
chksum 0xef
load 0x00000000, len 0, room 8
tail 0
chksum 0xef
load 0x00000000, len 0, room 0
tail 0
chksum 0xef
csum 0xef
csum err

at the ESPlorer.

I have tried various combinations of baud rate, write speed, dio / qio and flash sizes and all give the same result. In the case above the firmware.bin is my custom firmware which works on the esp8266 but I have also tried various demo firmwares from around the web.

Finally, if I try and run the against one of my working NodeMCU units it times out with a no packet header error.

Can anyone point me in the correct direction here?
User avatar
By lpares12
#73502 I had the same problem with an ESP-01. Trying to do it with dout instead of dio or qio solved it.

My current parameters are: -fm dout -ff 40m -fs 1MB. When flashing try always to specify everything according to your device to avoid getting default parameters from esptool.

Hope this solves your problem! I did the same as you, tried all combinations with qio/dio but never used dout until I saw that it's the default for some boards.