So you're a Noob? Post your questions here until you graduate! Don't be shy.

User avatar
By doktorinjh
#74539 I am attempting to connect to this website, with zero success:
I have tried the HTTPSRequest sketch as a guideline, along with others, and I have never been able to establish a connection. The ESP8266 can connect to other https websites, but as soon as I try to make simple substitutions for, the connect ceases. I've tried examples with and without the fingerprint, but it doesn't even appear to get that far before I get errors.

Is there the possibility that the .info domain is causing some sort of confusion?

Thanks for any help!
User avatar
By doktorinjh
#74562 As a follow up, it looks like the website uses TLS 1.2, so I'll need to update my firmware(?) to be able to implement that. I'm not certain which version I'm using, but I'll check that to be sure. I'll be following this guideline, unless anyone has a better suggestion.

User avatar
By doktorinjh
#74585 Update for those following along at home.

I turned on debugging and I get this message:

Code: Select allscandone
state: 0 -> 2 (b0)
state: 2 -> 3 (0)
state: 3 -> 5 (10)
add 0
aid 14

connected with nastar, channel 11
dhcp client start...
WiFi connected
IP address:
connecting to
State:   sending Client Hello (1)
Alert: handshake failure
Error: SSL error 40
Alert: unexpected message
Error: SSL error 40
Alert: close notify
connection failed
pm open,type:2 0

Searching that error code brings this up: "Two cipher suites supported by axTLS library on the ESP side (TLS_RSA_WITH_AES_128_CBC_SHA and TLS_RSA_WITH_AES_256_CBC_SHA) are not among the list of cipher suites supported by your server." So unless I can add other cipher suites to the ESP or get the website to accept one of these two, then I won't be able to connect.