Chat freely about anything...

User avatar
By SupDoc
#80460 I have had major personal interruptions and just getting back to the problem at hand.

Attached is my latest circuit:
1. I press and hold down the GPIO0 button
2, I tap the Reset button
3. I release the GPIO0 button.
4. I upload the current file.
I get more lights blinking on the CP2102 but the end result is the same -failure!
I have tried two different Sketches, and two different ESP-12's, all 4 combinations of which have worked on the NodeMCU, but will not work on the ESP-12
I have tried both the com port 3 & 11 - neither worked. Now I had to use com port 10 on the NodeMCU, if that is important.
If you find that my circuit is correct & procedure is correct, T have one last thing to try. I can build up my last of 3 ESP-12's and try again with this 3rd one. It' possible I may have damaged the other two with all kinds of previous connections to them. If that fails, then my last effort would be to try an FTDI controller instead of the CP2102.
User avatar
By QuickFix
#80462 According to this thread (referred to in the Wiki), you should pull GPIO2 high (with a resistor) to be on the safe side:
ESP8266 Wiki wrote:Notes :- GPIO2 It is considered safer to pull it high with a resistor on boot rather than leave it floating to avoid possible chip damage if pin is pulled high by your program but also see ... 524#p22524. GPIO1 (UART TX) also has an effect on boot if pulled low; it will not boot in this case.

Have you tried that yet, maybe flashing is successful, but running isn't?