Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By PastExpiryDotCom
rudy wrote:There were some ESP-01 that we built with an odd flash chip. There was a fix put in the ESP8266-Arduino project to deal with this. If you have an older version of the IDE then this ]might be the issue. (or not) I don't recall all the details since I never use the ESP-01 boards. I saw it in an issue entered into the issue system.

I'm assuming that you probably are using the Arduino framework. Even if no, it might be applicable.

Found out it was due to my wireless ROUTER security set to OPEN rather than WPA2-personal. The old esp-01 worked with OPEN security, while the newer ESP-01S REQUIRES WPA2 security! Of course this is not documented ANYWHERE.
User avatar
By schufti
#81090 that is definitely not the case.
that only depends on the esp8266 arduino core used to compile your sw as the bare esp chip only has bootloader and no wifi code at all. True even more for the other hw of the module....
Would you have tried to flash the old esp-01 with the new compiled code, the result would have been the same.
User avatar
By RichardS
#81092 Maybe you have an enemy that wants to drive you mad thinking there is a bug in your code....