As the title says... Chat on...

User avatar
By alistairwitt
#81819 Hi Folks,

I've been working with a Wemos D1 Mini on a small (spare time) project for a few months, developing on ESPlorer, both OS X and Win 10. I'm super impressed with the NodeMCU Lua firmware. I've generally been able to do a restart by using the 'Reset' button in ESPlorer, which I understand sends node.restart(). However, recently this hasn't been working, and I've had to use the hardware reset button instead. I can't identify what has caused it and am hoping someone give me a pointer on where to look further. The serial output is as follows:
Code: Select allNodeMCU custom build by
branch: master
commit: 4905381c004bdeaf744a60bb940c1906c2e052d4
SSL: false
modules: adc,cron,file,gpio,net,node,pcm,rotary,rtctime,sntp,spi,struct,tmr,u8g2,uart,wifi
 build created on 2019-04-15 02:03
 powered by Lua 5.1.4 on SDK 2.2.1(6ab97e9)
lua: cannot open init.lua
> Soft restart by user command
print(uart.setup(0, 115200, 8, 0, 1, 1 ))
stdin:1: attempt to call field 'restprint' (a nil value)
stack traceback:
stdin:1: in main chunk

I've tried re-flashing the firmware (a freshly built version), and also looking through the firmware code for 'restprint'. Could anyone suggest a tip on where I should look or what to try next?

Kind Regards,

User avatar
By alistairwitt
#81850 Some further info: Just re-flashed the firmware again, no files uploaded. Using ESPlorer on OS X (v0.2.0-rc5), using the built-in reset button, the results are as previously posted, i.e. fails. However, if I directly send by typing into the ESPlorer terminal node.restart(), it will instantly restart as it should. I've tried both multiple times and it's repeatable. At least I now have a software option from the terminal, rather than the hardware reset, though I still don't know why the built-in option isn't working. I wonder if this is turning out to be an bug in ESPlorer.