Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By woge1011
#82434 Hello all,
I have started working with ESP8266 with NodeMCU. Now I switched to the single ESP8266 E12-Module.

My problem ist now, that I aren't able to write data on the Chip. I use the "CP2102"-Module as USB-to-UART-Interface. I'm sure, that I wired the Chip properly.

Some strange thing is, that the TX-LED is only flashing (if I try to load some code to the Chip), If I connect the RESET-Pin to Ground.

What have I done?
    - external power supply with 3A
    - GPIO1 and GPIO0 to GND
    - EN/CH to 3,3V
    - TX and RX connected with USB-to-UART-Interface
Do you have some suggestions, what could be wrong?

Ps.: Arduino-IDE shows following error-code:
"esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header"
User avatar
By woge1011
#82481 So - I have an update....

Flashing and programming of the board is now possible.
I can't really say, what solved the problem, because I tried so many things...

I'm very happy now.

Could someone close the post???