So you're a Noob? Post your questions here until you graduate! Don't be shy.

User avatar
By davydnorris
#83717 It could also be that
- the flash was created for that size and is referencing the wrong user_init and certificate flash locations
- the locations the OP used to flash the above were not correct for the larger flash size
User avatar
By spaceman
#83797
softfoot wrote:The chip is a 25Q32 and is reported as 32Mb so I tried 32Mbit-C1 ---- on a reboot all I got out of the serial port was garbage.

In the end after going around in circles web searching and getting conflicting info on the meaning of the "-C1" I tried the 16Mbit-C1 settings and it worked!

So, my question is given my chip is a 25Q32 why on earth do I have to use 16Mbit-C1 ???


I have just received answer to this, from another person:

I think the 1.7 'prebuild' binaries are for 16Mbit flash,
and the esptool would flash it right with addresses for 16Mbit flash.


So this might be the end for this.
Espressif seems to be really problematic when it comes to trusting them with Firmwares..