Post topics, source code that relate to the Arduino Platform

User avatar
By RatTrap85
#84450 So I have a couple of ESP12-F modules that I am going to use for WiFi communications for another device. The requirements of the rest of the design is too much for the ESP as a standalone to handle so I more or less just want to use it as a modem controlled via Serial AT commands.

I have connected the ESPs to my devices
RESET -> 3V3
GPIO0 -> 3V3

The Serial line is set to a baud of 115200 which according to the data sheet is the default.

and yet I cannot get any meaningful communications or response to AT commands from the ESP devices.

I have tried every baud rate I can think of. at 74880 I can atleast see what looks like a verbose output on the ESP turning on. I have included this below.

Using baud 115200, when I send "AT" it acts like it is responding and outputs a message but it is just a few random characters like it would do if it were communicating at the wrong baud rate. I have tried all supported baud rates and none have yielded anything resembling a useful response.

ets Jan 8 2013,rst cause:1, boot mode:(3,7)

load 0x40100000, len 1856, room 16
tail 0
chksum 0x63
load 0x3ffe8000, len 776, room 8
tail 0
chksum 0x02
load 0x3ffe8310, len 552, room 8
tail 0
chksum 0x79
csum 0x79

2nd boot version : 1.5
SPI Speed : 40MHz
SPI Mode : DIO
SPI Flash Size & Map: 32Mbit(512KB+512KB)
jump to run user1 @ 1000

rf cal sector: 1017
rf[112] : 00
rf[113] : 00
rf[114] : 01

SDK ver: compiled @ Jul 1 2016 20:04:35
phy ver: 972, pp ver: 10.1


I have read through a lot of the forums but it seems like every answer I come across refers to directly programming the ESP and running their code on that device. Unfortunately I can't use the ESP in that way, and it is my understanding that it comes with AT firmware already on it and default is 115200 so I should be able to just connect it up and control it directly over serial right?

There must be something simple I am missing here. Can someone please tell me what I am doing wrong?
Last edited by RatTrap85 on Thu Nov 07, 2019 3:55 pm, edited 1 time in total.
User avatar
By RatTrap85
#84465 Solved this. It was a bit error rate of my 8MHz MCU that was causing all of the problems. Connecting it to a 16MHz MCU and changing the default baud rate of the ESP12 from 115200 to 57600 fixed the issue.

Also I apologize that I posted the same topic twice. The first one I did never posted until after I posted the second one.