So you're a Noob? Post your questions here until you graduate! Don't be shy.

User avatar
By jaredes291
#84466 K so I just got my esp module and tried to connect it to my pc with an arduino zero with no program loaded
my pin connection went as follows:
esp zero
rx => rx
tx => tx
CH-PD => 3.3
VCC => 3.3
when I tried to send "AT" I got no response on 9600 baud and 115200 Baud the only data I got was on 74880
and that was this
Code: Select all ets Jan  8 2013,rst cause:2, boot mode:(3,6)

load 0x40100000, len 2592, room 16
tail 0
chksum 0xef
load 0x00000000, len 0, room 8
tail 0
chksum 0xef
load 0x00000000, len 0, room 0
tail 0
chksum 0xef
csum 0xef
csum err

I even tried it on the arduino uno with the same result.
Any help would be appreciated Thanks
User avatar
By Col_Tech
#85441 I am having similar problems and am also a newbie, so I cannot advise but maybe if we compare problems we can see what is wrong.

My ESP01 is not responding to my Arduino, using an echo on all serial data, so I have been trying to talk with it direct. On startup I get a lot of data (at 74800 baud) but then no response to any AT commands.
The last data from the ESP01 is unreadable, so I was wondering if it may have changed baud rate, but 9600->115200 all come up blank.
The wifi is findable on my laptop.
I do have ret + nl on my serial monitor.
Had same problems running ESP01 on its own and in the cradle (which has inbuilt 5v->3v converter, but you lose access to reset pin)
Have swapped over all cables
Reset was not pulled down when my Arduino code was running, just using it now as it is advised on arduino forum when doing pass through USB<->serial

Does any of this help you? Any ideas?
You do not have the required permissions to view the files attached to this post.