So you're a Noob? Post your questions here until you graduate! Don't be shy.

User avatar
By RedPanda
#84645 Hello,
i'm currently working on a little side project with an NodeMCU esp8266 board.
Already worked on a few microcontroller projects in the past but especially working with this board and wifi chip is still pretty new to me. So far i enjoy it.

Now, to get all my code to work, i need to install a pretty old sdk version for the esp8266 chip on the arduino ide (to be specific SDK 1.3). Already pulled the latest git version (commit 5653b9a59baa25094c891d030214aa956bec452c) of the code and i think i also got the folder structure right (hardware -> esp8266com -> esp8266). If i now try to get the still needed binary tools with the script it always exits after a hash mismatch of the linux64-xtensa-lx106-elf-gb404fb9.tar.gz package. I also tried downloading the packages manually from the links i found in the package_esp8266com_index.template.json file but that doesn't work because the provided links only bring up 404 errors.

Is there another way to get those needed files or to successfully installing the sdk 1.3 version on the arduino ide?