Your new topic does not fit any of the above??? Check first. Then post here. Thanks.

Moderator: igrr

User avatar
By haiflosse
#88679 Hi!
I have here a wemos D1 mini pro which I use already about 2 month. Till now I had no problem with programming.
After I tried a sketch and would like to upload an other sketch I will get now the following error:
Arduino: 1.8.13 (Windows 10), Board: "LOLIN(WEMOS) D1 mini Pro, 80 MHz, Flash, Legacy (new can return nullptr), All SSL ciphers (most compatible), 16MB (FS:14MB OTA:~1019KB), v2 Lower Memory, Disabled, None, Only Sketch, 921600"

Executable segment sizes:

IROM : 309432 - code in flash (default or ICACHE_FLASH_ATTR)

IRAM : 27760 / 32768 - code in IRAM (ICACHE_RAM_ATTR, ISRs...)

DATA : 1280 ) - initialized variables (global, static) in RAM/HEAP

RODATA : 1888 ) / 81920 - constants (global, static) in RAM/HEAP

BSS : 25600 ) - zeroed variables (global, static) in RAM/HEAP

Der Sketch verwendet 340360 Bytes (32%) des Programmspeicherplatzes. Das Maximum sind 1044464 Bytes.

Globale Variablen verwenden 28768 Bytes (35%) des dynamischen Speichers, 53152 Bytes für lokale Variablen verbleiben. Das Maximum sind 81920 Bytes. v2.8

Serial port COM4


Chip is ESP8266EX

Features: WiFi

Crystal is 26MHz

MAC: f4:cf:a2:d8:43:99

Uploading stub...

Running stub...

Stub running...

Changing baud rate to 460800

Traceback (most recent call last):

File "C:\Users\privat\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.7.3/tools/", line 65, in <module>


File "C:/Users/privat/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.3/tools/esptool\", line 2916, in main


File "C:/Users/privat/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.3/tools/esptool\", line 104, in inner

return func(*args, **kwargs)

File "C:/Users/privat/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.3/tools/esptool\", line 705, in change_baud

self.command(self.ESP_CHANGE_BAUDRATE, struct.pack('<II', baud, second_arg))

File "C:/Users/privat/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.3/tools/esptool\", line 347, in command

p =

File "C:/Users/privat/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.3/tools/esptool\", line 292, in read

return next(self._slip_reader)

File "C:/Users/privat/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.3/tools/esptool\", line 2045, in slip_reader

raise FatalError("Timed out waiting for packet %s" % waiting_for)

esptool.FatalError: Timed out waiting for packet header

esptool.FatalError: Timed out waiting for packet header


The connection to my port is ok.
When I press the reset button on the wemos I will get the following message:

ets Jan 8 2013,rst cause:2, boot mode:(3,7)

Hope somebody can help me how I can program again my wemod D1.
kindly regards for any answer.
User avatar
By Mr.Gil
#88727 They can be very confusing when errors occur. I use the Arduino IDE and it crashes and sometimes even locks up. Worse it spits all types of errors. If they are Java probably the IDE if not as you indicate it is something in the module. What has saved me several times over the past few weeks is I power down everything then restart it. Next I load a simple known good program such as blink. If that works the hardware should be fine, if not you probably have a problem with the ESP but be sure to try another cable and or USB port before giving up. If it comes alive it is probably in your code. I got similar errors when I to write past the end of the "EEPROM".
User avatar
By dbarn
#88968 I have the same error and error log (except for language and mac). I have tried several Wemos D1 Mini ESP8266 devices and they all provide the same results. The system was working until I rebooted my PC yesterday.

When downloading starts - after the connection - the LED on the board blinks. When the reset button on the board is pressed, the console window displays a line of garbage (I think this is due to the baud rate being set to 460800). There must be some port communication since the mac address is read back.

I have read many of the online comments on problems like this and none o the suggested fixes have made a difference.

Thanks, Dan
I think this might be a windows 10 update feature.
I am running Windows 10 Pro on an AMD Ryzen 3900 12 core processor with 32 GB memory.
Windows update is enabled so everything should be current.

Does anyone have any ideas on how to proceed from here?