Chat freely about anything...

User avatar
By Nemo Resh
#91911 For the last 5 months, we have successfully managed to create an SSL connection to Firebase via ESP8266 (ESP-01).
Two weeks ago the connection stopped working aside for a few individual times, a day after we couldn't connect at all.
-> AT+CIPSTART responded ever since with ERROR CLOSED.

We tried switching between different WiFi networks and got the same results.

1. We are managing to create TCP connections with HTTP websites.
2. The WiFi module is connected to an STM32, the communication is established using AT commands via UART (baud rate 15200).
3. We tried issuing AT commands using a direct UART connection between the STM32 and the PC (independent of our code). The commands were given through a Terminal window in our PC - AT+CIPSTART still failed (same error).
4. We have 4 different WiFi modules - ESP8266 (ESP-01). They all reacted the same.
5. In the past we had a similar issue, back then we set the SSL size to 4096 (the maximum size and it helped).
6. We managed to connect to other HTTPS websites using an SSL connection
-> when connecting to these sites via AT+CIPSTART we got a few times the response CONNECTED OK, for the rest we got CLOSED OK.

AT commands details
AT+RST (reset the module)
AT+CWMODE=1 (set the Wi-Fi mode to station mode)
AT+CWJAP="SSID","PWD" (connect to a Wi-Fi network)
AT+CIFSR (get the Wi-Fi module IP)
AT+CIPSSLSIZE=4096 (change the SSL buffer size)
AT+CIPSTART="SSL","",443 (establish a SSL connection)
AT+CIPSEND=300 (send data)

Wi-Fi module:
STM32 microcontroller:


If anyone can help, we would appreciate it very much.

Thank you in advance!
Wi-Fi module front and back.png
Wi-Fi module front and back
AT command image.jpeg
The sequence of AT commands we sent, and the error we received in the AT + CIPSTART command
User avatar
By Nemo Resh
JurajA wrote:Firebase switched to TLS 1.2 and AT firmware doesn't support it

Thank you so much for your answer!!!
Can you please send us a link that verifies this?
We tried to find on the internet, but we couldn't find one.
(We also sent an email to Firebase, but they still didn't answer us).