Chat freely about anything...

User avatar
By esperanzo
#92307 I have an ESP-07 which does not react to AT commands as opposed to an ESP-12F which works properly with AT commands.
I did upload a blink sketch to the ESP-07 using the arduino IDE, and it worked fine.
The I also successfully updated to the latest firmware, but AT commands still do not work.
There is just no response at all.
Attached is a screenshot of the firmware update.
Is there a problem with the latest firmware or am I missing something else here?
2021-09-10 21_26_25-ESP8266 DOWNLOAD TOOL V3.8.8.png
User avatar
By esperanzo
#92325 Sorry for not being precise enough.
AT commands did not work in the first place, so I uploaded a sketch to see if this worked.
I am aware that the sketch replaced the AT firmware, and I did the firmware update shown in the screenshot after I had tested with the sketch.
The newly installed firmware re-installs the AT commands, but as I wrote it still did not work.
User avatar
By esperanzo
#92328 Flashing with write_flash --flash_size 1MB 0x0 boot_v1.7.bin 0x01000 at/512+512/ 0xfb000 blank.bin 0xfc000 esp_init_data_default_v08.bin 0xfe000 blank.bin 0x7e000 blank.bin
worked, but AT commands still show no response at all.
I have a second ESP-07 which still has the factory firmware which gives me the following output @74880 baud at boot.
2nd boot version : 1.5
SPI Speed : 40MHz
SPI Mode : QIO
SPI Flash Size & Map: 8Mbit(512KB+512KB)
jump to run user1 @ 1000

My newly flashed ESP-07 shows boot version 1.7 while the other values are the same.
The AT problem is the same as on both of the ESP-07.
I did also flash my ESP-12 with the latest firmware 1.7 and this one has no problems with AT commands.

My suspicion is, that the ESP-07 either have a flash ROM problem beyond 0x1000, which is the jump start address for AT commands, or the clock frequency for AT commands is not within the correct limits.