Chat freely about anything...

User avatar
By AcmeUK
The terminal program I use, picocom, doesn't support this baud rate

For this reason, in my linked post, I point you to CoolTerm!
The boot time messages can point you to all manner of issues when your code does not run as expected.
I always set my main code to run at 74880 so that I can see if there are any boot messages indicating issues with my code.
User avatar
By ChrisO
#93359 Thank you for the hint, AcmeUK.
I'm 100% Linux, CoolTerm is a bad option for me, got it to work with picocom, just for reference:

/usr/bin/picocom -ex -b 75000 -d 8 -p n --omap crcrlf /dev/ttyUSB0

I can read output from the boot-loader. read_flash
> Detected crystal freq 27.65MHz is quite different to normalized freq 26MHz.
That would mean baud-rate 79632, but who knows how accurate this probing is. Maybe it's a counterfeit from China^WEurope :D
Anyway, 75000 works for me and am happy to have learned something thank to you, AcmeUK