Chat freely about anything...

User avatar
By bluscape
#94525 I've loaded factory firmware onto an ESP-WROOM-02D but it does not respond to AT command and displays garbage after a reset.

I've tried various sources and versions and I've also tried it on various ESP8266 boards at all possible baud rates, but they all give the same result. All the boards was working previously and are working with custom firmware.

What am I doing wrong? Or why is not working?

The sources I've tried:
v2.2.0.0_esp8266/AT_Binary_Lists/ESP8266_AT_binaries.html ... 2152281939

The versions I've tried:

The boards I've tried:
2x Different ESP-DevkitC_V1 boards with ESP-WROOM-02D modules
1x NodeMCU board with an ESP-12F module

I'm using ESP8266 DOWNLOAD TOOL v3.9.2 with the following settings:
    Checkbox checked
    Selected "factory_WROOM-02.bin"
    Address set to 0x0
    SPI Speed: 40MHz
    SPI Mode: QIO
    DoNoChgBin Checked

Programming procedure:

When I click start, the software will display the module info:

flash vendor:
68h : N/A
flash devID:
26 Mhz

It will the display the module AP and STA addresses and start flashing the module and will display "FINISH" in green.

What am I doing wring? Or why is it not working?
User avatar
By JurajA
#94529 The AT 2 binary for esp8266 build by Espressif uses pins 15 as TX and 13 as RX for AT commands.
For standard pins you can use ... ter/extras

I recommend you to use the 1.7.5 version. It is much better.