So you're a Noob? Post your questions here until you graduate! Don't be shy.

User avatar
By Vivadego
#94826 Today was my first day in trying to start with the ESP8266.
From what I already understand it wasn't the smartest move to go for an ESP-01, however I do have a particular project in mind where I want to use it for.

What I have been trying to do is Flash WLED tot the ESP-01, but at some point just tried to flash anyting.

I am using an USB CH340 with "power - uart" swich like this one

I have tried different method's so far, flashing through arduino IDE, Tazmotizer, and the WLED installer page. I even tried flashing with python at one point, but since I am completely new to any sort of programming that was just a bad idea :D

I went back to try and flash a basic blink program through the Arduino IDE. The problem I seem to keep encountering is the same: unable to connect to the board. See code below for the exact error I get.

Code: Select allExecutable segment sizes:
ICACHE : 32768           - flash instruction cache
IROM   : 231724          - code in flash         (default or ICACHE_FLASH_ATTR)
IRAM   : 26797   / 32768 - code in IRAM          (IRAM_ATTR, ISRs...)
DATA   : 1496  )         - initialized variables (global, static) in RAM/HEAP
RODATA : 876   ) / 81920 - constants             (global, static) in RAM/HEAP
BSS    : 25608 )         - zeroed variables      (global, static) in RAM/HEAP
Sketch uses 260893 bytes (27%) of program storage space. Maximum is 958448 bytes.
Global variables use 27980 bytes (34%) of dynamic memory, leaving 53940 bytes for local variables. Maximum is 81920 bytes. v3.0
Serial port COM7
Connecting........_____....._____....._____....._____....._____....._____.....____Traceback (most recent call last):
  File "C:\Users\vince\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\3.0.1/tools/", line 66, in <module>
  File "C:/Users/vince/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/3.0.1/tools/esptool\", line 3552, in main
    esp.connect(args.before, args.connect_attempts)
  File "C:/Users/vince/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/3.0.1/tools/esptool\", line 529, in connect
    raise FatalError('Failed to connect to %s: %s' % (self.CHIP_NAME, last_error))
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header

Now ofcourse I have tried trouble shooting the error. Most of what I encounter is people using an older version of the USB serial connector in which de GPIO0 and GND pin need to be connected in order for the board to go into flash/ boot mode. From what I understand, the switch on the CH340 board (prog - uart) should take care of this.

After 7 hours of trouble shooting I am at a loss where to continue with it. Any help would be very much appriciated.
User avatar
By QuickFix
#94835 After setting the switch to "Flash" mode, you have to manually reset the board (while it's powered) by briefly pulling pin 6 LOW. After that you can start the flashing process.
User avatar
By Vivadego
#94839 @tepalia02,
Do you mean the CH340 usb serial connect board or the esp-01 8266 board?
The drivers for the CH340 board installed fine and windows does recognize it.
Not completly sure If I understand what you mean

I have tried pulling pin 6 low through use of a breadboard. That is, pulling low means connecting it to the ground pin right? However, I will try that again since I am not sure if my timing was right. Does it matter how much time is in between de reset (pulling pin 6 low) and de starting process of the flashing?
User avatar
By Vivadego
tepalia02 wrote:Hi, have you done the board installation part properly? Without any problem?

The CH340 usb connector as well as the installation of the ESP-01 8266 seem to have been properly installed.
I am trying to find out about the tools settings in de Arduino IDE, have tried some different settings. So far no luck.