Your new topic does not fit any of the above??? Check first. Then post here. Thanks.

Moderator: igrr

User avatar
By tayyabch
#94127
AlexanderMason wrote:Hello, I've experienced a problem with NodeMCU board. I have several esp8266 modules and a NodeMCU which I found more convenient for fast prototyping. I made a simple sketch which creates soft AP, webserver and handles a simple html page with couple of forms. After data is submitted into forms server esp8266 forwards acquired data through rs232 to regular arduino uno.
Its pointless to post code because I've tried many variations and ended up with same results.
Also! visit on Alaska Tracking to tarck your parcels

Whenever I flash esp8266 module everything works flawlessly. When I upload same sketch into NodeMCU AP goes very glitchy, e.g. it drops connection, wont allow me to connect and whenever I manage to finally connect it sends cropped data to browser. I choose correct board type,. however I tried different boards and settings but nothing helps. I tried to power up it from separate lab PSU = same problems.
Probably there's something needs to be done which Im missing? Or its simply a faulty chip?
Thanks in advance!
User avatar
By Alaric
#94179
kevinroland wrote:try to erase the flash to clear invalid RF calibration data after switching SDK version (for example version used by the original firmware and the version used by your code)

It was to wait for reciept of several more ESP-12 modules to arrive in an effort to prove or disprove the failure of the one module.