Sming - Open Source framework for high efficiency native ESP8266 development
User avatar
By gaara
#64336 Hi,

We've having some serious issues with ESP12-E and Sming. After updating to Sming 3, we started using ConfigNetwork and the ESP12-E stopped working. Any rom we use now that used to work doesn't work any more.

We used another ESP12-E and we noticed that it worked fine, again, until we started using ConfigNetwork.

When uploading Arduino sketches, the boards work fine. However, when uploading a Sming rom, with rBoot, the boards don't work.

Does anyone know if ConfigNetwork could be doing something to the boards that might be confusing rBoot?

Might the RF calibration data have anything to do with this? Is there a way to clear them?

Thanks.
User avatar
By gaara
#64338 We've found the issue. Seems that the esp init data has been corrupted. Using esptool to flash esp_init_data_default.bin found in the Espessif SDK resolves this: https://github.com/nodemcu/nodemcu-firm ... n/flash.md

We haven't tried ConfigNetwork yet to see if indeed that is what caused this, will keep you posted.

Regards,

Alex