Post topics, source code that relate to the Arduino Platform
User avatar
By TechChevy
#76020 I have been working with the ESP-01 for a IoT project for school with an Arduino Nano to take measurements and update the data from multiple locations. I had no problem flashing an empty sketch to the Nano and typing in AT commands into the command prompt. I then went on to using the SoftwareSerial library in order to send the commands automatically and then show the replies on the serial monitor. I was getting garbage characters when running the software serial at 115200 and the serial monitor at 9600. I stumbled unfortunately across the old AT command to change the baud rate and now it doesn't respond to any commands. I have another ESP-01 on hand and I tried using the AT+UART_DEF command on the other one to change it to 9600. After I got the OK response, I couldn't send anymore commands to that one either. I have tried flashing both of them with the newest firmware but no matter what I do they can't establish a connection with them again. I have looked at other posts and tutorials and have came up with nothing that works. Is there a way to recover these two ESP's and if so how do I change the baud rate without this happening again? Looking back I probably should have just changed the rate at which the serial monitor ran at. Thanks in advance for any help you can provide!