Post topics, source code that relate to the Arduino Platform

User avatar
By CaptClaude
#79131 I have the TTGO (version A) ESP8266 board that I got on AliExpress. Works great except for one thing: If I upload from my laptop, it works. If I unplug & replug the USB (or other 5V source), it does not run until I hit the reset button. While not running, the serial monitor shows an endless stream of
Fatal exception (0):
epc1=0x40100000, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000000, depc=0x00000000
at the bootloader speed of 74880bd.
Very strange. Works after reset but not without a reset. Connects to WIFi, blinks LEDs, controls Neopixels, etc. But not until I press reset.
Programming with Arduino IDE using attached parameters and regardless of whether it's in a breadboard connected to other stuff or hanging in mid-air. Tried a pullup on D8 without success.
Anyone ever seen this? I'm ready to hit it with a hammer. :evil:
You do not have the required permissions to view the files attached to this post.
User avatar
By CaptClaude
#79151 The Arduino IDE gives me the option of erasing Sketch only, Sketch + WiFi & Whole Flash Contents. I've tried all three to no effect, but I'm not sure that's what you're suggesting. If not, a pointer would help.

Here's the strange part. Let the thing sit for a few hours (as in overnight) and it will power up and run WITHOUT reset. Since nothing in the software should change with it powered off (overnight), this strikes me as a hardware issue somehow, which is why I tried the pullup on D8. I've tried stripping the sketch down to the bare minimum involving the display, might try just a blink sketch and see if not talking to the display at all changes anything.

When it boots, I see a date of June 2013 IIRC. I'm not 100% clear on the process of updating the base firmware -- unless I do that every time I load a sketch and say flash whole flash contents.

This is the thing I am dealing with on AliExpress.