Downloading and installing the new Arduino IDE for ESP8266

Moderator: igrr

User avatar
By kcmopilot
#80091 All,

I have a project using painlessMesh on 8266.
Been working great for several months.
Unfortunately, the latest version of the 8266 core causes compilation errors with painlessMesh.
Is there a way I can specify an older version in the "Additional Board Manager URL", instead of using

http://arduino.esp8266.com/stable/packa ... index.json

Thank you!
User avatar
By QuickFix
#80126 The only way is to install the older library manually.

However, it's better to fix a library and make it compatible again with the latest ESP-core. :idea:
User avatar
By McChubby007
#80131 Whenever I move to a newer esp-core I always keep the current (older) one - copy it somewhere, and then when I have the new one installed, I diff all the code to see what has changed. It might seem tedious to do this, but this way not only do you know of new features added, but also api/lib changes which may break your code. Just an idea for you.