Downloading and installing the new Arduino IDE for ESP8266

Moderator: igrr

User avatar
By RichardD
#80503 Just trying out new Wemos mini for project.
Gone through all install for Arduino IDE on Mac and installed USB to serial drivers, all went very well! Easy!
Yes, then uploaded the blink programme, worked no problems, well not quite.
The error window said that upload speed maybe too high, but it worked (Yay).
So next test wanted to upload program simple program that captures GPS serial signal and displays in serial box just to test GPS module with Wemos mini.

Now I have warning and errors!! see Below!

Uploading 230192 bytes from /var/folders/8_/h07t8n2j4z3djn414lrw_3g00000gp/T/arduino_build_750741/Raw_GPS.ino.bin to flash at 0x00000000
warning: espcomm_send_command: didn't receive command response
An error occurred while uploading the sketch
warning: espcomm_send_command(FLASH_DOWNLOAD_DATA) failed
warning: espcomm_send_command: wrong direction/command: 0x01 0x03, expected 0x01 0x04
error: espcomm_upload_mem failed

Any suggestions are greatly appreciated.
Many Thanks in advance.