Advanced Users can post their questions and comments here for the not so Newbie crowd.

Moderator: eriksl

User avatar
By spaceman
#83695 Hi all


I have an Open-Smart 5v ESP8266 module, that I bought in 2016.

Image


The module came with AT v0.40.0.0, and SDK v1.3.0, created by Ai-Thinker:

Image



2 days ago I updated the module's Firmware,
and now the module has AT v1.6.2.0, and SDK v2.2.1, created by Espressif:

Image



The Flashing succeeded, as can be seen in the screenshot,
yet there's one critical problem..


With the old firmware, I was able to connect (AT+CWJAP) to my WLAN, 100% of the times that I tried.
With the newer firmware, I am not able to connect to my WLAN, 100% of the times that I tried.


I should mention that nothing else changed:
Not the module's HW, not the computer, not the power source, only the Firmware.


I should also add that my router is an old 3COM router,
so my suspicion is that the older firmware was calibrated well for older routers too,
while the newer firmware is not calibrated for it well, and so I cannot connect to the WLAN at all.


Is there anything I can do with the AT v1.6.2.0 and SDK v2.2.1 Firmware, to make it connect so well like the previous firmware did?
(instead of throwing away my router and buying a new one)


Thank you all for your help