Post topics, source code that relate to the Arduino Platform

User avatar
By beejayf
#85993 Hello,

on my very first try with an ESP8266 I was planning to control some Neopixel LEDs with WiFi.

I am using the Arduino IDE and a NodeMCU Lua Lolin WiFi V3 Modul ESP8266 ESP-12E. I was able to upload some simple WiFi Demo which worked flawlessly.

No I was uploading the following code for a simple LED demo:

Code: Select all#include <Adafruit_NeoPixel.h>
#ifdef __AVR__
  #include <avr/power.h>

#define PIN 6

Adafruit_NeoPixel strip = Adafruit_NeoPixel(1, PIN, NEO_GRB + NEO_KHZ800);

void setup() {
  strip.setPixelColor(1, strip.Color(255, 255, 255));;

void loop() {

The LEDs are not triggered and checking the IDEs serial monitor I got

Code: Select all ets Jan  8 2013,rst cause:4, boot mode:(3,6)

wdt reset
load 0x4010f000, len 1384, room 16
tail 8
chksum 0x2d
csum 0x2d

I have tried flashing the latest firmware and such in the meantime - still the problem presists.

Can anyone point me in the right direction?