Chat freely about anything...

User avatar
By holopaul
#81841
eriksl wrote:- make a config sector like this and write it (using esptool(.py) to 0x7a000 (plain image) or 0xfa000 (ota image) and please note the empty line at the end. This will enable the UART output.
Code: Select all%4afc0002%
wlan.mode=0
wlan.client.ssid=xxxxxxxxxx
wlan.client.passwd=xxxxxxxxxxx
io.0.1.mode=8
io.0.1.llmode=7




Well that worked!
First i did a flash_dump and found that sector kinda empty. This is after a fresh flashing. Maybe this will tell you something about the cause, I'm still clueless.
Code: Select all%4afc0002%

wlan.mode=1



Then i just flashed it like you described above. It connected to the wifi in a blink. That was my main problem, not the UART being disabled.
Thanks a million for telling me about this workaround. It's going to be very helpful in the long run to write the config directly to flash.
User avatar
By eriksl
#81854 I am still very much wondering why it didn't work in the first place. Are you willing to do some debugging for me, as soon as I uploaded the new version with UART enabled?

Yes, I guess it pays off sooner or later to have a config in text form :-) As it is more difficult to handle in the code compared to a binary format config, which I started off with.
User avatar
By holopaul
#81857
eriksl wrote:I am still very much wondering why it didn't work in the first place. Are you willing to do some debugging for me, as soon as I uploaded the new version with UART enabled?


Without a doubt ! You can count on me. :geek:
User avatar
By eriksl
#81874 That's the spirit :-)

I've made a Makefile called "release" which allows me to draft a release very easily. So that's what I did and there is now a release 22 that has the UART workaround in it (UART TX is always enabled, even if not configured).

Please try with this version when convenient.