So you're a Noob? Post your questions here until you graduate! Don't be shy.
User avatar
By kylehunter
#65099 Hey guys,

Having tons of issues with my first attempts at using this board. I have a lot of experience using arduino's and various microcontrollers, but my current project requires WiFi connectivity. I ordered the esp-12 and have had trouble getting it to be stable at all.

No matter what sketch I use, even if it just a loop printing to serial, it is unbelievably unstable. It will print fine for a while, then non stop exception errors and stack traces. The exception numbers vary each time, usually 0/29/8. It's just super intermittent. It will work fine for 20 minutes and then just spam errors until I reset and re upload my sketch. I notice that it occurs almost every time I reset the board.

I assume it is something with my power setup, since it seems like they are very sensitive, but I think I am doing it right. I'm using this schematic for the board:
Image

A CP2102 Serial cable: https://www.amazon.com/gp/product/B01A0BOGHG/ref=oh_aui_detailpage_o03_s01?ie=UTF8&psc=1

Voltage is regulated with a LD1117V33 voltage regulator, from a 2AMP 5V wall power supply.

I connect the serial cable's 3.3v power to my common power rail, because it doesn't upload without that (I feel like this may be my issue).

I'm really bad at drawing schematics, so here's a picture of my voltage regulator board and the esp board. To upload I bring GPIO0 to low and have reset low and as it starts to upload bring it high. Thanks a lot for any help.

Image

Image

EDIT: Also, forgot to add, I started using it just as it came without flashing any new firmware. I thought that it could be the issue, but then I flashed the lasted nodemcu, and there was no change.
User avatar
By Mitchell QTT
#65149 Suggestions:
1. You could get yourself a Wemos D1 mini or NodeMCU development board.
They have voltage regulators and FTDI on board, which will ensure the problem is not in those parts.
These are cheap and targeted to developing software. Once finished, you can load your software on an ESP-12 board.

2. Which NodeMCU version are you using?
If you are using the old version from the original NodeMCU and you did not get a recent one from https://nodemcu-build.com/ , I suggest you do that first.
I had some trouble getting NodeMCU flashed in the first place, and then to get ESPLORER to work, and to get LUA files on the device.
I got it working, but in the end I went to the Arduino software. It is C++ but that's no problem for me.
It's easy to find a sketch which just connects to WiFi, so you can test your system with the certainty that the software-part is OK.
User avatar
By rudy
#65153 It looks like you are using the ESP-12E. It is more sensitive to power issues compared to the later ESP-8266F and the more stable and latest ESP-12S. Looking at your pictures I would say your problem is the amount of wire you are using. You have to provide the ESP with stable power and that will not be the case with the way you are connecting everything.

The first thing I would recommend is to put the bypass cap right across the 3.3V and ground connections on the module with as short a lead length as you can. Use tubing to insulate the capacitor leads. Hopefully this will be all you need but if you still have instability problems then you need to do more.

I have previously replied to other people's posts about the same problems. I will provide the following link for you to look at.

viewtopic.php?p=58818

viewtopic.php?f=6&t=11068&start=4

The power requirements for the ESP-8266 are a lot more demanding compared to most of the Arduino type processors. (some newer stuff also includes the esp device)

Take a look at your ground and power path. How long are they? You have more than enough capacitors but hoe long is the path from the 3.3V terminal on the ESP - through the capacitor - and then to the ground terminal of the ESP-12. Way too long. I also would put the regulator on the same board and close to the ESP.

Most likely the highest demand device that you will need to power with the regulator will be the ESP. So move the regulator close to it so it can do it's job where that power is needed.
User avatar
By schufti
#65162 as rudy allready mentioned:

don't use jumper wires where not necessary -->
keep supply path as short as possible -->
use (resistor) wire cuttings where possible

move the regulator close to the esp, put gnd pin direct into gnd rail of breadboard
put small caps (100n) close to the regulator
put large electrolytic close to esp.

don't forget pullup on gpio2

usually you don't need 3V3 supply for CP2102 it is powered from USB, if it is not working that way there definitely is something wrong. I usually only connect Rx/Tx/DTR/RTS and gnd, this provides functionality for standard programming. To run and get serial console, you have to disconnect DTR/RTS.